PayU South Africa Service Degradation - Bank link/3rd party

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted May 12, 2025 - 17:00 CAT

Investigating

[South Africa]
Card transactions are currently being affected on PayU's SANDBOX / Staging environment that will affect card transaction testing.

Please note that this issue does not apply to our Production environment in any way.
Engineers are investigating.
Posted May 12, 2025 - 16:06 CAT
This incident affected: PayU Staging (Sandbox) environment.