PayU South Africa Service Degradation - Bank link/3rd party

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted Jun 06, 2025 - 18:15 CAT

Monitoring

The FNB link has been stable for 30min. We will keep monitoring for a while. We are still in communication with them to try and understand the problem.
Posted Jun 06, 2025 - 15:50 CAT

Investigating

[South Africa]
Card transactions for FNB are currently affected.
Engineers are reaching out to the Bank.
Posted Jun 06, 2025 - 15:05 CAT
This incident affected: Acquiring Links - South Africa (South Africa Card Acquiring FNB).