Nedbank Issued cards high decline rate

Incident Report for PayU Africa

Resolved

Nedbank has confirmed the issues was resolved
Posted May 25, 2026 - 17:42 CAT

Investigating

Nedbank has informed us of the current ongoing issue affecting Nedbank issued cards causing high decline rates.
The Nedbank team also informed us their technical teams are working on resolving the issue.

More updates to come as they become available.
Posted May 25, 2026 - 12:05 CAT
This incident affected: Issuing Links PayU South Africa (Nedbank Issuing).