Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 09, 2025 - 22:00 CAT
Scheduled
Notification received of up coming Capitec maintenance in their production environment. They informed that an increase in latency may be experienced and potential downtime of about 10min somewhere within the maintenance slot.
Posted Jun 09, 2025 - 16:34 CAT
This scheduled maintenance affected: Acquiring Links - South Africa (South Africa Capitec Pay).