Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 17, 2025 - 02:00 CAT
Scheduled
We would like to inform you of the ongoing migration of Nedbank issued cards to the Entersekt ACS Cloud Solution.
The migration of Nedbank American Express cards is currently in progress. We will notify you once this process has been finalized. Please take note of the following:
Entersekt will be conducting scheduled maintenance on Thursday, 17 October 2025, between 02:00 and 04:00.
During this maintenance window, brief service interruptions may occur.
Posted Oct 06, 2025 - 09:58 CAT
This scheduled maintenance affected: Anti-Fraud (South Africa - 3DSecure).