Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 05, 2026 - 01:00 CAT
Scheduled
Please note that Capitec will be conducting planned maintenance that may affect payments requiring the Capitec Bank app. Clients could experience difficulties completing transactions during this period.
Capitec issued cards maybe impacted too.
Posted Jul 03, 2026 - 15:03 CAT
This scheduled maintenance affected: Issuing Links PayU South Africa (Capitec Issuing) and Acquiring Links - South Africa (South Africa Capitec Pay).