PayU South Africa Service Degradation - Capitec Pay

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 15:51 CAT

Update

We are continuing to monitor for any further issues.
Posted Aug 21, 2025 - 15:27 CAT

Monitoring

Processing seem to have stabilise. We will continue to monitor.
Posted Aug 21, 2025 - 15:27 CAT

Investigating

[South Africa]
Capitec Pay transactions are currently being affected.
Engineers are investigating.
Posted Aug 21, 2025 - 15:16 CAT
This incident affected: Acquiring Links - South Africa (South Africa Capitec Pay).