PayU South Africa Service Degradation - Nedbank issued cards
Incident Report for PayU Africa
Resolved
Nedbank has confrimed that the issue has been resolved.
Posted Apr 26, 2024 - 11:30 CAT
Monitoring
Nedbank issued cards are intermittently affected
Nedbank is aware of the issue and are investigating.
Posted Apr 26, 2024 - 10:07 CAT