A fix has been implemented and we are monitoring the results.
Posted Jul 07, 2025 - 15:43 CAT
Update
Bank links are back up, we will continue the monitor.
Posted Jul 07, 2025 - 15:42 CAT
Investigating
PayU has noted a degradation in the connections to all banks for processing cards. Bank Card transactions are affected.
Posted Jul 07, 2025 - 15:35 CAT
This incident affected: Acquiring Links - South Africa (South Africa Card Acquiring ABSA, South Africa Card Acquiring Nedbank, South Africa Card Acquiring SBSA, South Africa Card Acquiring FNB).