Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 21, 2026 - 00:00 CAT
Scheduled
Card transactions for merchants using Nedbank acquiring may be temporarily impacted during this period. Transactions on Nedbank-issued cards are expected to process as normal, although they are not entirely exempt from potential disruption.
Posted Feb 20, 2026 - 13:24 CAT
This scheduled maintenance affected: Acquiring Links - South Africa (South Africa Card Acquiring Nedbank) and Issuing Links PayU South Africa (Nedbank Issuing).