PayU South Africa Service Degradation - 3D Secure Provider

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 17:26 CAT

Investigating

[South Africa]
3D Secure transactions are currently being affected due to an up stream 3D secure provider issue.
Engineers are attending to the problem.
Posted Apr 02, 2025 - 15:42 CAT
This incident affected: Anti-Fraud (South Africa - 3DSecure, Premium 3DSecure Provider).