PayU South Africa Service Degradation - RCS

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted Aug 29, 2025 - 15:41 CAT

Investigating

[South Africa]
RCS transactions are currently being affected.
Engineers are investigating.
Posted Aug 29, 2025 - 15:10 CAT
This incident affected: Acquiring Links - South Africa (South Africa RCS).