PayU Service Degradation: Mastercard

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 16:10 CAT

Investigating

High failure rates observes for Mastercard transactions through 3DS.
We are monitoring the situation and will provide feedback.
Posted Jul 15, 2026 - 10:13 CAT