South Africa - 3DSecure issues being experienced
Incident Report for PayU Africa
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 15:23 CAT
Monitoring
PayU is aware of 3DSecure processing issues currently being experienced via Bankserv.

Our Engineers are in contact with Bankserv and will advise.
Posted Feb 20, 2024 - 15:05 CAT
This incident affected: Anti-Fraud (South Africa - 3DSecure) and PayU (PayU Payments API, PayU Redirect Payment Page).