Verification is currently underway for the maintenance items.
Posted Jun 13, 2025 - 01:24 CAT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 13, 2025 - 01:00 CAT
Scheduled
Please be advised that PayU will be performing emergency database maintenance early tomorrow morning that will require a restart of the Database and Gateway service. We expect about 30min of downtime.