PayU South Africa Service Degradation - EFT
Incident Report for PayU Africa
Resolved
This incident has been resolved.
Posted Nov 30, 2024 - 11:17 CAT
Investigating
[South Africa]
Please note that we are noticing increase in processing time and failures for EFT processing.
We have reported this to our vendor and are monitoring closely.
Posted Nov 29, 2024 - 11:50 CAT