PayU South Africa Service Degradation - 3D Secure Provider
Incident Report for PayU Africa
Resolved
This incident has been resolved.
Posted Dec 21, 2023 - 16:39 CAT
Investigating
[South Africa]
3D Secure transactions are currently being affected due to an up stream 3D secure provider issue.
Engineers are attending to the problem.
Posted Dec 21, 2023 - 14:32 CAT
This incident affected: Anti-Fraud (South Africa - 3DSecure).