We are still observing high failure raters for card processing. No change yet.
Posted May 07, 2025 - 01:56 CAT
Update
No further information currently available. Still seeing high failure rates.
Posted May 07, 2025 - 00:58 CAT
Investigating
[South Africa] Card transactions are currently being affected. Currently Mastercard transactions seems to be affected more. Engineers are investigating and reaching out to acquirers.