The issue has been identified and a fix was applied. The system is functioning optimally and within expected parameters. We will monitor.
Posted Jun 25, 2025 - 12:01 CAT
Investigating
We are currenty experiencing issue s with our Staging/Testing area where the Redirect Page is showing a blank screen. The teams is investigating the issue. Will keep you updated.
Posted Jun 25, 2025 - 11:29 CAT
This incident affected: PayU Staging (Sandbox) environment.