PayU South Africa Service Degradation - Discovery Miles

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 01:27 CAT

Investigating

[PayU South Africa] Discovery Miles transactions are currently being affected.
Engineers are investigating with Discovery.
Posted Apr 14, 2026 - 14:40 CAT
This incident affected: Acquiring Links - South Africa (South Africa DiscoveryMiles).