PayU South Africa Service Degradation - 3D Secure Provider
Incident Report for PayU Africa
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 00:17 CAT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2024 - 14:31 CAT
Investigating
[South Africa]
3D Secure transactions are currently being affected due to an up stream 3D secure provider issue.
Engineers are attending to the problem.
Posted Mar 14, 2024 - 13:52 CAT
This incident affected: Anti-Fraud (South Africa - 3DSecure, Premium 3DSecure Provider).