PayU South Africa Service Degradation - Bank link/3rd party

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted Jun 07, 2025 - 18:02 CAT

Monitoring

Bank link stable currently, but we will keep notification in monitoring while bank investigate, to give updates.
Posted Jun 07, 2025 - 08:09 CAT

Investigating

[South Africa]
Card transactions for FNB are currently being affected.
Engineers have reached out to the bank who is currently investigating.
Posted Jun 07, 2025 - 07:44 CAT
This incident affected: Acquiring Links - South Africa (South Africa Card Acquiring FNB).