A fix has been implemented and we are monitoring the results.
Posted Jul 15, 2026 - 08:54 CAT
Investigating
[South Africa] Please note PayU has received word from Capitec that they are having issues with their bank App. This affects all Capitec Pay transactions. We are currently in touch with Capitec to ensure we can provide updates as soon as they are available.
Posted Jul 14, 2026 - 15:39 CAT
This incident affected: Acquiring Links - South Africa (South Africa Capitec Pay).