Update from Capitec: Please note that the Capitec App issue has been resolved. The team will be continue to monitor and will be on standby ready to support. We have noted recovery, Capitec Pay transaction being procressed successfully.
Posted Aug 20, 2025 - 19:07 CAT
Update
Update from Capitec: Please note that the Capitec App is still down. All teams are actively working on the issue and we will update accordingly. Note the time and impacts outlined below.
Posted Aug 20, 2025 - 18:09 CAT
Identified
Capitec has confirmed that theis bank App is down, this affects the processing of Capitec Pay transactions.
Posted Aug 20, 2025 - 16:00 CAT
This incident affected: Acquiring Links - South Africa (South Africa Capitec Pay).