PayU South Africa Service Degradation - FNB

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted Jun 22, 2025 - 23:28 CAT

Monitoring

Experiencing sporadic disconnects from FNB affecting card processing. We are in contact with the bank to help troubleshoot.
Posted Jun 22, 2025 - 09:27 CAT

Investigating

[South Africa]
Card transactions to FNB are currently being affected.
Engineers are investigating.
Posted Jun 22, 2025 - 09:21 CAT
This incident affected: Acquiring Links - South Africa (South Africa Card Acquiring FNB).