South Africa - Discovery Miles
Incident Report for PayU Africa
Resolved
This incident has been resolved.
Posted Jan 21, 2024 - 18:48 CAT
Identified
Please note that we are aware of issues processing Discovery Miles transactions. The vendor is aware of this and they are looking into it.
Posted Jan 21, 2024 - 14:54 CAT
This incident affected: Acquiring Links - South Africa (South Africa DiscoveryMiles).