PayU South Africa Service Degradation - Mastercard

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted Mar 30, 2025 - 10:10 CAT

Investigating

Please note we are picking up a general decrease in processing time for MASTERCARD transactions. We will be monitoring this and give updates if we receive more information.
Posted Mar 29, 2025 - 14:28 CAT