Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 26, 2024 - 22:00 CAT
Scheduled
Please be advised that Nedbank have advised us that they will be performing a planned maintenance and that transactions may be affected during this period.
Posted Nov 26, 2024 - 17:00 CAT
This scheduled maintenance affected: Acquiring Links - South Africa (South Africa Card Acquiring Nedbank).