PayU South Africa Service Degradation - Bank link/3rd party

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 19:03 CAT

Monitoring

We are noting gradual recovery. We will continue to monitor the processing closely.
Posted Jul 03, 2025 - 17:28 CAT

Investigating

We have noted an issue affecting bank card transactions. It seems Mastercard transactions are mostly affected at the moment but we are investigating and reaching out to the acquirers for more info.
Posted Jul 03, 2025 - 16:49 CAT
This incident affected: Acquiring Links - South Africa (South Africa Card Acquiring ABSA, South Africa Card Acquiring Nedbank, South Africa Card Acquiring SBSA, South Africa Card Acquiring FNB).