PayU South Africa Service Degradation - Discovery Miles

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted Jul 05, 2026 - 12:44 CAT

Monitoring

We noted recovery this morning, we will continue to monitor.
Transactions are processing normally currently.
Posted Jul 05, 2026 - 10:29 CAT

Investigating

[PayU South Africa] Discovery Miles transactions are currently being affected. Payers using Disco Miles payment method are not able to complete transactions successfully.
Engineers are investigating with Discovery.
Posted Jul 05, 2026 - 00:25 CAT
This incident affected: Acquiring Links - South Africa (South Africa DiscoveryMiles).