PayU South Africa Service Degradation - Bank link/3rd party

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 16:04 CAT

Monitoring

We have received confirmation from the bank that the issue has ben resolved.
Posted Nov 28, 2025 - 16:00 CAT

Investigating

We have noted a spike in errors again, we will continue to engage with FNB.
We will provide more detail as we receive it.
Posted Nov 28, 2025 - 14:24 CAT

Monitoring

We will monitor for an hour to ensure full recovery.
Posted Nov 28, 2025 - 13:45 CAT

Update

We are noticing steady recovery on the FNB transactions. We will continue to monitor.
Posted Nov 28, 2025 - 13:08 CAT

Identified

The issuer has confirmed that they are currently investigating the issue.
PayU will keep you posted.
Posted Nov 28, 2025 - 12:09 CAT

Investigating

We have noted a spike in failures on FNB platform issues.
The team is in touch with the bank to get more information on the issue.

We will provide more information as soon as we receive it.
Posted Nov 28, 2025 - 11:35 CAT
This incident affected: Acquiring Links - South Africa (South Africa Card Acquiring FNB).