PayU South Africa Service Degradation - Card acquiring

Incident Report for PayU Africa

Resolved

Some banks have stated that they see recovery.
Posted Mar 31, 2025 - 00:19 CAT

Identified

Card not Present transactions are currently being affected. It seems there may be a problem between Bankserv and the acquiring banks. We will share more information when we receive some.
Posted Mar 30, 2025 - 20:53 CAT