PayU South Africa Service Degradation - 3rd party

Incident Report for PayU Africa

Resolved

The payment provider has confirmed resolution of the issues.
Posted Nov 28, 2025 - 13:47 CAT

Identified

Payflex has informed us that are having system issues.
They have confirmed that they will provide more information as it becomes available.
Posted Nov 28, 2025 - 13:06 CAT
This incident affected: Acquiring Links - South Africa (South Africa Payflex).