Settlement Reporting service is currently offline. Engineers are working towards restoring the settlement reporting functionality
Incident Report for PayU Africa
Resolved
The service has been restored.
Posted Jul 25, 2024 - 12:04 CAT
Investigating
We are currently investigating this issue.
Posted Jul 25, 2024 - 10:17 CAT
This incident affected: PayU (PayU South Africa Reporting).