PayU South Africa Service Degradation - Capitec Pay

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted Mar 22, 2025 - 20:37 CAT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 22, 2025 - 19:53 CAT

Investigating

[PayU South Africa] Capitec Pay transactions are currently being affected
Engineers are investigating.
Posted Mar 22, 2025 - 17:52 CAT
This incident affected: Acquiring Links - South Africa (South Africa Capitec Pay).