PayU South Africa Service Degradation

Incident Report for PayU Africa

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 00:41 CAT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2025 - 00:29 CAT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 01, 2025 - 00:25 CAT

Investigating

Please note PayU is experiencing a degradation of service.
Engineers are investigating to resolve as soon as possible.
Posted Apr 01, 2025 - 00:15 CAT