We will be undergoing scheduled maintenance during this time.
Posted Jul 10, 2025 - 17:36 CAT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 10, 2025 - 17:14 CAT
Scheduled
During this period, ABSA anticipates ABSA issued card transactions to be affected, which will affect ABSA cardholders, and the processing of 3DSecure on ABSA issued cards.
Posted Jul 10, 2025 - 17:14 CAT
This scheduled maintenance affects: Issuing Links PayU South Africa (ABSA Issuing).